URGENT UPDATE REQUIRED FOR 3DICOM

5th October 2021 – Due to a recently diagnosed bug, we ask that you please update to 3Dicom v2.7.1 (Latest) to continue using the 3Dicom software.

en_USEnglish